Introducing TM Database software 

Translation Memory (TM) database is a specialized database program that is particularly helpful in creating, managing, and presenting your translation. Database is based on free-format text entries. Each entry contain one source and one translated sentence. Each sentence can be up to 600 characters long. You can store an unlimited number of entries in database. Attribute fields allow classification of entire entries or of individual items in entries. For instance, you can add attributes to identify the Manual name, Product type, Language, Page number or string number, revising, date, etc. Powerful search functions let you quickly find/replace the information you’re looking for.
System Requirements

- Windows NT/2000/XP/Vista/W7/Linux (Wine) (XP recommended)
- Pentium III processor (Pentium IV or above recommended)

- RAM 256 MB (512 MB or above recommended)

- Screen resolution at least 1024x768
Features:
- Import .XML / .INX / .XLS /.TMX* / .RTF* / TMX/ Trados Workbench Import files

- Support easy edit/find/modify/replace entries

- Translate .INX / .TXT / .XML /.XLIFF / .TS / .UNI / .XLS* / MS Visual Studio resources(.res) / Java Properties(.properties) / PHP sources files

- Fixing errors, changing Font / Frame / Paragraph / or mark sentences in translated .inx file,

- Finding and marking the un-translated sentences in PDF file (support Adobe Acrobat v.7 or above)
- Automatic pretranslate function

- Spell check function

- Mark the un-translated sentences in Inx file.

- Not necessary to install any additional software: (Java, .NET, Visual C++ Runtime Library, etc.)

- Small size (launch from USB flash disk without installation)

* - under testing

Installing TM database
To install TM database, double click on file. Install Wizard should launch automatically as follows:
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Click Yes to continue.
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Please select the Installation language and click OK.
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Click Next to continue.
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Read License Agreement and click I Agree.
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Set the path you would like to install Software and Next to continue.
We recommend accepting the default path.
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Click Finish to exit.
Launching TM database
Click TM database Icon on your Desktop: 
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The main window opens.
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Opening a Database

The first time you start TM database, an empty window appears on your computer. To use TM database, you need to either open an existing database or create a new one. To familiarize yourself with the program, we recommend opening one of the sample databases by following these steps:
From the File menu, select the Open database... as follows:
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The standard Windows Open dialog appears.
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Click on the sample database SAMPLE.TMF, and confirm your selection by clicking on Open.

Browsing the Database

Press Browse button, and can browse through a TM database, using Prev / Next button: 
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Also you can use Up/Down, Pg Up/ Pg Down, Home / End key on keyboard.
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For get detail information for each item check Show Detail item
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Detail information show above each item.

For Example “4250_ES5100_rus Desktop PC page=24(2)” meaning follow:

4250_ES5100_rus  -Manual Name

Desktop PC  

 -Product Category

page=24(1) 

 -Location of sentence (page 24, first sentence)
Sasha 



 -Translator’s name

Search in database
Of course, you can also look up specific entries in your TM database. To do so, type the phrase to look for into the search field as follows:

1.Click the mouse in the search field. The cursor starts to blink.

2.Type your search term into the search field and press the [Find] button.
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For browse results use Prev /Next button or Up/Down, Pg Up/ Pg Down key on keyboard.

Note:You can select a category for search only in this category or select All for search in all categories.
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Creating a database

Create empty database

Select Menu->File->New Database for create new
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The standard dialog appears on your screen.
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1. Select the file type field as No file, 

2. Select Product type and Language and type description if need

4. Click OK
Create database from file
Before you can use TM database to create, manage, and edit items, you must first

create a database. For creating database can use Text (.TXT), XML, Rich text Format (.RTF), InDesign Interchange(.INX), Translation Memory Exchange (.TMX), Trados Workbench(.TXT) and Excel (.XLS) files.
Preparing
You need prepare two (TXT/XML/INX/RTF) file. Open the English PDF file and translated FDF file and save them as XML

Open PDF file and save select File->Save As
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in Save As window select XML 1.0 / Text (Accessible) / Rich text format as save format and press Save button 
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Import

From the File menu, select the Create DB. 
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The standard dialog appears on your screen.
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1. Type Translator’s name, 
2. Select Product type 
3. Select Target language

4. Click Browse(upper) button

In the Open dialog, select the non-translated (English) text file and confirm your selection by pressing Open.
5. Click Browse button

In the Open dialog, select the translated text file and confirm your selection by pressing Open.
6. Click OK
Editing entries
Once you have created your own database, you can start editing entries and building your database. The left and right offers should conform each other.
Press Edit button and additional buttons appears.
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For delete unused left and right items press Delete button
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For aligning (move right item up or down) press Up or Down button
Before aligning:
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After aligning:
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For addition of the bottom offer in previous press Join button

Before:
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After:
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You can edit sentences. For Apply changes press Apply button
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After editing database don’t forget save database. From the File menu, select the Save Database... as follows:
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If there is empty items (deleted items), From the Database menu, select the Delete empty fields and save database again
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Translation
Utility allow you translate text base on the TM database. Also you can view statistics.
From menu, click Translation as follows:
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Translation window opens.
[image: image33.png]Translate =1olx]

Flo View Translation Stafistcs Tools _Sektings

[an 7| [Tansiate Untranslated | [ Book |
Find Fnd [7 &
| N |

D [Source Translation Comment [ |~

D [Source Translation Definition B





Translate InDesign file
The tool can translate InDesign Interchange files(.INX), so you need export file.
Preparing

Launch Adobe InDesign software and open InDesign file.

Select File->Export… as below:
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In Save as field type filename, select InDesign Interchange as format and press Save button
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Open file

Open English INX file for translation as follows:
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The standard Windows Open dialog appears.
Click on the file, and confirm your selection by clicking on Open.
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Fix mistakes (optional)

Press Fix file button for fix small mistakes (for Power users only)
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The dialog box will appears as below:
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Click Yes if you want concatenate two or more parts of one sentence or No for cancel.
WARNING! Click Yes button only if you know what you doing. Otherwise, the translated file will corrupted.

Translate
After open file select the Category, and click Translate button

Text will translate partially as follows:
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Translation options
Press Setting in menu to view options
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Show translated string – show current translated string (for debug)
Find First Element – find the first item in database and use it for translation*
Detain statistic – show additional statistic info*
Exact translation – translate item only if match is 100%*
Translate clauses – translate clauses

Skip Table of Contents – don’t translate Table of Contents

Remove picture’s frame – delete the frame from pictures in translated file

Mark translation – mark translated elements in translated file* 

Change fonts – change fonts from English to target language in translated file

Align text – align the paragraphs in translated file

Change leading - change leading of font in translated file

Mark untranslation – mark untranslated sentences in translated file

Auto find in PDF – finding and highlight the selected sentence in PDF file

* - function may be different depend from type file

Statistic
This window show the percent of translation and name of products used for reference
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Translation untranslated items
Press Untranslated button for look untranslated items.
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You can see all untranslated items in list below (left bottom). For translate an untranslated item manually select the item in list. Content will copy to left edit window. Type the translation in right edit window and press Add to DB button to add this item to TM database

Also you can select sentence from right list and edit it.
Note:Check the Delete Item from list check box, if you like delete this item from untranslated sentences list after add it to database.
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 Press to find and highlight the sentence (or part) in opened PDF file
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 Press to mark the sentence in opened PDF file
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 Press to find the sentence (or part) in opened Database

[image: image48.png]Sort



    Press to sort untranslated items by alphabet
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    Press to translate the sentence via google translator
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 Select the percent of match for find in Database

[image: image51.png]


    Press to copy the sentence to translated window
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    Press to add the pair of sentences to Database
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  Select the product category for translated sentences
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 Tip for delete translated sentence from list after adding it to Database
Save file

Translated file can save as show below. 

File will save in same folder with source file with added “XXtrs” to filename. Where “XX” show the percent of translation.
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Then you can open translated .inx file in Adobe InDesign and use it for reference as follows:
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Translate .UNI (UTF16LE) file

1. Launch utility and select Translation for open the translation window.
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2. In opened window select Menu->File->Open file for open a source file.
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3. Select Unicode text files as Files of type
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4. Type your translation in Translation column.
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5. Select Menu->File-> Save file for save file.
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Hotkeys:

Ctrl - B – copy from source

Ctrl - T – translate row
Ctr l - Enter –  confirm row
Ctrl - S – Save file
F7 – Spell check

Translate .XML (Android UI) file

4. Launch utility and select Translation for open the translation window.
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5. In opened window please select Menu->File->Open file for open a source file.
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6. Select XML file as Files of type
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4. Type your translation in Translation column.
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6. Select Menu->File-> Save file for save file.
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Hotkeys:

Ctrl - B – copy from source

Ctrl - T – translate row
Ctrl - Enter – confirm row
Ctrl - S – save file
Ctrl - F – find the selected text in DB

F7 – spell check

Adding translations to Database for reference

1. Confirm translated rows (use <Ctrl>+<Enter> key)
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2. Select Menu->File-> Add Checked Items to DB
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3. Select Language, BU, etc. and press Add button
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4. Save Database

Spell check function
This function can check the TM database translation records or opened file. It can use one or two dictionaries.
Hot key <F7> or Menu->Tools-Spell Check
Program will highlight the wrong word in red.

You can ignore word, add word to user dictionary or change word from suggestion list.

If word highlight in red, but no suggestions, you can use online check (some languages)
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Online translator function
This function can translate ssentence using online servise
Menu->Tools->Translator
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Terminology search function
This function provides the translation for some terms, 
Menu->Tools->Terminology Search
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Word reference dictionary function
This dictionary provides word translation, including verb conjugations
Menu->Tools->RWordReference
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Orthographic dictionary function (only Russian)
This dictionary provides orthographic information, including verb conjugations. Menu->Tools->Russian dictonary
[image: image74.png]=101

[Caoeo Cheek

[Opdorpaguueckui crosape ii
c)

cnoBo, -a, Mk c08, €08, -aM  (pemz. -Ghunoc. Moeos
Cnoso, -4 (e Hauane feino Caoea)

[Bonswof Tonkoski cnosaps
1. CNOBO, -&; ww. cAoEa, CAGE, -am  (yormap). cnosecs,
cnosee, -aw; cp.

1

EAUHMIA F3bIKA, CYXALLEH ANA HISHIEGHIA OTAENSHOTD
oA, fosmopurns c. Sanowmurns ¢. Hanucams ¢
Vnompeturms ¢. Mepeeecinu c. Moduepkmyme ¢. Herars
[nodxodnuee c. Heanaromoe c. Yemapeauiee ¢. Cyxetuoe ¢
|Pyccroe c. Mamuncros c. Podcmesnnuie crosa. Crosaps .





*This is testing alpha-version, if you have encountered an errors or problems or you have any suggestions, please email: Sasha_p@asus.com or yehongmei@yandex.ru
